alexdeathway ,
@alexdeathway@programming.dev avatar

First one are method name, second one are status name.


def open_file_dialog(self):
       self.dialog_file_open = True
       pass

Yoda level preference war.

devfuuu ,

Yes.

morrowind ,
@morrowind@lemmy.ml avatar

Where's file_dialogue_open

janAkali ,

To be fair, it's also missing open_dialog_file, dialog_open_file and most crucially file_open_dialog

xmunk ,

We're all trying our best to ignore the Americans and you bring up m/d/y... why!

Goodie ,

Whatever is more useful goes first.

For example, if this we're a list of UI text strings, finding all of the dialogue options together might be useful.

If, instead, this is a series of variables already around one dialogue, then finding the open or close bits together would be useful.

crispy_kilt ,

First of all, it's spelled dialogue

Sotuanduso ,
@Sotuanduso@lemm.ee avatar

Two wars can exist simultaneously.

stufkes ,

OP's username is in German, so it's probably half-German-English code

crispy_kilt ,

Germans learn UK English

stufkes ,

Dialogue is UK English. But I just looked it up and apparently 'dialog' is a computer term, but should not be used on its own but rather in combination, such as 'dialog box'.

smeg ,

Americans sadly got there first and defined all the computer terms, that's why it's a TV programme but a computer program. I can deal with that though, helps distinguish computer things from real things!

RustyNova ,

I don't know and that's the problem :(

I keep asking myself what to choose, only for changing it a day after cursing myself to choose a stupid name.

Big endiant is great for intellisense to quickly browse possibilities, since it groups it all in the same place. But that's also a detriment when you know what you want. You can start typing without the prefix but you'll have to go through the better suggestions of intellisense first.

Little endiant is the same thing, but in reverse. Great when needed, but bad for browsing.

Although I do have some fix I'm starting to use. But it's not applicable everywhere, and not in every language.

What I do is use module as prefix. Instead of dialogue_file_open, I create a file_open in the dialogue module, allowing either directly calling file_open, or dialogue::file_open. Using intellisense on the module allow for easy browsing too!

Although in OP's post I'd rather have file_open_dialogue as it convey the more significant meaning, being to open a file, first. Then "dialogue" is just the flavour on top

oldfart ,

For me it's simple.

Pseudo-OOP in C which takes dialog* as a forst argument? dialog_open_file

Otherwise - make it human readable

sudo42 , (edited )

Big endiant is great for intellisense to quickly browse possibilities, since it groups it all in the same place.

If only someone would train a program… we could call it a Large Language Model… to knowingly group the names together so we wouldn’t have to choose between human-readable format or dB format.

Guess that will never happen because instead we’re stuck using “AI’s” to inflate stock prices instead. /s

I remember seeing a proposed language that would allow each programmer to choose what name to use for each item. Don’t like ‘open_file’? Choose to see it as ‘file_open’ every time you review the file in the future.

While we battle with each other endlessly, we keep forgetting that the computer doesn’t care.

Fish ,

Variety is the spice of life.

olafurp , (edited )

I prefer everything to be how you would read it as text. So create_file_dialog it is. Honorable mention is to have it namespaced in a class or something which I think is best. file_dialog.create or dialog.create_file or even dialog.file.create

brunofin ,
@brunofin@lemm.ee avatar

I agree. I say open door so the function should be named openDoor.

Honestly nowadays none of that matter if you're using any remotely modern IDE with good indexing and a sensible search, you can start typing however you mind works and it will find it no matter how it's named.

humbletightband ,

I have never thought about it

jjjalljs ,

I worked at a place where all the DB column names were like id_user, id_project. I hated it.

ShortFuse ,

I didn't really care about this thread until I read this comment.

rockSlayer ,

Create a file handler class to avoid the issue

magic_lobster_party ,

Eww, that’s OOP

deadbeef79000 ,

Meh, a class is just a struct of function pointers.

nikaaa ,

FileDialogFactory

MrOxiMoron ,

A third option there is

mexicancartel ,

A fourth there option is

PenisWenisGenius ,

sjajvxuwjdofgwu

AjsgGhS77bndugxg

gehshagfahcdvwjdvwjd

AjsgGhS77bndugxg (2)

Opisek ,

A fifth option there is

PenisWenisGenius , (edited )

New file

New file (2)

New file (3)

New file (4)

lunarul ,

open_dialog_file or dialog_open_file?

Hazzia ,

Can't remember which is which but if it's organized in a top-down way (broad category first) that's just easier to look at and find stuff in the file system. I don't want to have to actually read and mentally process the names of every single file to figure out if it's the one I need. Sure, the "human readable" names are fine and good when you don't have hundreds of them you're trying to look through, but big projects I find are way easier to parse with the category naming.

ooterness ,

US Army logistics catalogs are organized this way. "Cookies, oatmeal" instead of "Oatmeal cookies" because it's a lot easier to find what you need an a giant alphabetical list.

blanketswithsmallpox ,

How any large organization gets away with not using YYYY-MM-DD format is beyond me.

Taking over some of my previous directors files is like chaos.

How anybody publishing entire internet memos without a date being on the first page is beyond me. Like wtf am I reading a PDF from 15 years ago or last month?

morgunkorn ,
@morgunkorn@discuss.tchncs.de avatar

As a rule of thumb, I always put action verbs at the end of method names

evatronic ,

I do one, the other senior dev does the other. We fight about it in pull requests.

livingcoder ,

Your team needs to have a coding standards meeting where you can describe the pros and cons of each approach. You guys shouldn't be wasting time during PR reviews on the same argument. When that happens to me, it just feels like such a waste of time.

nikaaa , (edited )

This sounds like the typical plot of a story from The Codeless Code.

Edit: How about this story specifically?

  • All
  • Subscribed
  • Moderated
  • Favorites
  • [email protected]
  • kbinchat
  • All magazines